Arkadiy Bogatskiy  
Dmytro Bogatskiy

**Blgo Assistant – Go (Baduk, Weiqi) database for players of all levels**

Paper for the 2nd Baduk Conference in St. Petersburg

**Contents**

- Preface
- Known Go Databases programs.
- Short description of the BIgo Assistant
- BIgo Assistant Databases
- User interface and main features of the BIgo Assistant
- Main distinctions between BIgo Assistant and other Go databases.
- How to improve in Go with BIgo Assistant
- Conclusion: Ideal Go Database

**Preface**

Classification is the one of the main tasks in studying any complicated thing. Main classification problem in Go (baduk) consist in creating detailed opening library. Because of very large amount of variations in Go, there is impossible to compose manually more or less deep detailed opening reference like that is done for chess debuts. There were made only for corner openings: joseki (jungsuk) and not enough fully. There are several joseki (jungsuk) dictionaries (in hardcopies) with 5 - 10 – 15 thousands of variations. Actual quantity of reasonable joseki variations which already played by professionals is much more.

In 1986 elder co-author of this paper had tried to make manual fuseki (posuk) classification by only first 4 moves of about 300 games from the “Kido Yearbook 1984”. It took many hours of work.

We know about only one printed full board fuseki (posuk) reference: “Encyclopaedia of Fuseki”, which have published Nihon Kiin in 1991. About 2000 professional games were manually classified by first several moves. The Encyclopaedia shows first 35-40 moves of each game with some variations and commentaries.

Now, in computer era, problem of Go opening classification became solvable. Modern computers is allows to build Fuseki/Joseki trees (and even more complicate structures without loss of information) from hundreds thousands and millions games and provide convenient interface for use data.

We are confident that today each serious Go player should have Go database program for reference and self-education. For last few years there were created several programs of that kind. Our program - Bigo Assistant is one of them.
Known Go Databases programs.

We give an alphabetic list of largest English language Go Database programs without detailed analysis of their features.

1. **Gobase** - online Go database located at the [http://gobase.org](http://gobase.org) includes about 28 000 professional games with engine for pattern searches of joseki and fuseki in pro games, plus articles, players biographies, etc.

2. **Go Info** – first known Go Database program have design in 1996. Go Info allows the user to search for positions and patterns which occur in the recorded games. This software has 2,000 recorded professional games. All standard database features is supported.

3. **Kombilo** ([http://www.g0ertz.de/kombilo](http://www.g0ertz.de/kombilo)) + **GoGoD** ([http://www.gogod.demon.co.uk](http://www.gogod.demon.co.uk)) more 22 000 professional games. GoGoD mainly is collection of Go games in sgf format. Its main purpose is to search for games in which a given pattern or position occurs. You can also search for other criteria (like time period, players, events). Kombilo itself is not contains any Go game records but you can import games in SGF format (Kombilo is now included on the GoGoD CD).

4. **MasterGo** ([http://mastergo.com](http://mastergo.com)) - about 20 000 professional games. Fuseki/joseki search engine and games search included.

Short description of the BIgo Assistant

BIgo Assistant ([http://bigo.ufgo.org](http://bigo.ufgo.org)) is full-featured game of Go (Baduk, WeiQi) Games/Fuseki/Joseki Database with more than 30 000 professional games & more than 1 000 000 games of strong amateurs.

BIgo Assistant destined for users who want to improve their playing strength. We hope that it will be useful for Go players of all levels: from 20 kyu to high professional dans.

BIgo Assistant distributes in 3 packages with different databases sets for different kind of users:

- **Full.** Full set of game records and fuseki/joseki databases built from it. This version of program assigned for Go fans. It needs about 2GB space at the hard drive of the computer.
- **Profi.** This version of Database include only professional games. It assigned for Go professionals, who are not aware that amateur games could be useful for them and for users with shortage of free space in hard drive of computer.
- **Tiny.** Small subset (25 000) of Full database assigned for Go beginners and for those who wants become familiar with program features.

BIgo Assistant is designed for Windows 98/ME/NT/2000/XP.

**BIgo Assistant Full Edition Databases**

The base of BIgo Assistant Full Edition Databases is Go Games Database which consist of about 1 060 000 Go game records of strong (approximately equal to European 5 dan), very strong (6-7 dan) amateurs and professionals (over 32 000 professional games, part of which are anonymous for now (only players rank is given)).
There are very few games of weak players. Most games included in Database were played on 19x19 board on even. However there are many handicap games and a few 9x9 games.

**Main Go Opening Databases**

Go Opening Databases built from all game records of the full Game Database:

- Go Opening (fuseki, posuk) Database database - about $2.4 \times 10^9$ variations
- Fuseki database for $\frac{3}{4}$ of the board (without 1 corner) Database - more than $1 \times 10^{16}$ variations.
- Fuseki database for half board (19x11) - more than $4 \times 10^{11}$ variations.
- Joseki (jungsuk) database for 12x12 corner - more than $2 \times 10^{12}$ variations
- Joseki database for 9x9 corner - more than $1.5 \times 10^{13}$ variations.

Other Databases:

- Manually entered Joseki Database. This database managed by separate program BIgo Joseki.
- Professional, Pro & SemiPro, Players Subbases of the best Chinese, Korean and Japanese Go players Go Games Subbase with Fuseki/Joseki Subbases

**Subbases**

Subbases are subsets of full the Go Games Database:

- Professional Go Games Subbase with Fuseki/Joseki Subbases built only from professional games
- Pro & SemiPro Go Games Subbase with Fuseki/Joseki Subbases built from professional and strongest amateur games.
- User defined Custom Subbases.

**Examples**:

1. all high dan (7-9) professional games in year 2003
2. All games from ‘Baduk Yearbook 2002’
• Predefined and user defined Players Subbases of the best Japanese, Chinese and Korean Go players with correspondent Fuseki/Joseki Subbases:

Cho Chikun (1383 games), Cho Hunhyun (1265 games), Fujisawa Hideyuki (514 games), Go Seigen (821 games), Kato Masao (1002 games), Kobayashi Koichi (980 games), Lee Changho (1075 games), Ma Xiaochun (718 games), Nie Weiping (545 games), O Rissei (510 games), Rin Kaiho (1117 games), Sakata Eio (731 games), Takemiya Masaki (753 games), Yoo Changhyuk (815 games), Otake Hideo (779 games) and many other.

Dia. 2. Players Subbase list. Vertical scrollbar of the list is slightly unusual.

Dia. 3. Players

Custom and Players subbases are easy manageable. User can create new subbases (Dia.3) or delete unnecessary ones.

Building all necessary files for Full database took more than 2 months at the computer with CPU Athlon 1.7 XP and RAM 1 GB.
Blgo Assistant Profi Edition Databases
Go games database includes about 20 000 records of professional games.

Blgo Assistant Tiny Edition Databases
Go games database includes about 25 000 game records (2 700 professional games).
Fuseki/Joseki databases and subbases for the Pro Edition and Tiny Edition are the same as in Full version but much less in size because they built from correspondent restricted game records sets.

Data sources. Verification data
Games of professional Go players entered from about 50 Yearbooks (Japanese Kido, Korean Baduk and Chinese WeiQi), about 200 monthly Go magazines, other Go publications and from Internet are included in Professional Games Database.
Games of high level amateur Go players collected from printed sources and Internet Go servers:
- CyberKiwon - does not operate anymore
- Dashn - http://dashn.com
- IGS - http://igs.joyjoy.net
- KGS - http://kgs.kiseido.com
- Neostone - http://www.neostone.co.kr
- NNGS - http://nngs.cosmic.org
and others
There are continuous update of databases provided. Monthly updates of the Go Games Database are:
- about 15 000 - 20 000 strong amateur games (generally from Internet Go Servers)
- about 200 - 500 professional games.
We have created special Go diagrams recognition software Blgo OCR. This program is distributes as info donationware with free registration. To get game record in SGF format after recognition user have send us recognized file stored in special BCR format which produces Blgo OCR. We convert game record, keep the copy to update our Games Database and send user via e-mail SGF record for free. Because of that, every month we receive a lot of professional games from Blgo OCR users.

Input game records problems
Duplicates of the game records is a big problem for any Go database.
There is impossible to find all game record duplicates using only Dyer signature (a signature assigned to the game which encodes the positions of move 20, 40, 60, 31, 51, 71). Although it in practice almost characterizes a game uniquely, but only almost. For big game databases Dyer signature is not enough. New games before including in database (I mean user enabled part of the database) should pass more severe check.

Examples
1. One game record is unfinished and consists only from 70 moves, another one is complete (say 220 moves). Check procedure based on Dyer signature will report that the games are different.
2. There are two pairs of forcing moves for the 1st game: 71 – 72 and 73 – 74. If game sequence for 2nd game will be: 73, 74, 71, 72, then these games, naturally, will have different Dyer signatures.
In our program we fulfill multiple checks of new added games during updates Fuseki/Joseki Databases. Program reports about any suspicious for duplicates games with the same variations for different board parts. After that we compare those games manually. No one game delete from our source Game Database.

Next problem is a different spelling of player names and tournament names in different sources. We have special tool for managing names dictionary. We have collected, for example, 16 different spellings of Lee Changho name and 22 for Cho Hunhyun name in it for now.

Another problem is rank differences for different Go servers and different countries. So we have two rank types in our program: ‘Rank’ – real player rank and so called ‘Game Rank’ - standardized rank of the player. Game rank of the 4d* player from IGS server before 2001 is 6 ama dan, today 6d* from IGS is equal to 6 ama dan.

User interface and main features of the BIgo Assistant

This section covers main features of the BIgo Assistant with short description of them.

General features

- **Multi windows SDI.** User can create and use as many dynamic Go boards with games, fuseki, joseki and tables with games lists as he(she) need.
- **Compactness.** Only Control Panel with information panel for current active Go board. After switch to another Game/Fuseki/Joseki window information in the Control Panel changes automatically.
- **Many options for interface tuning.**

User can change number of games for loading into games list, show/hide columns with information for the games list, change bitmap for board background and stones, show/hide numbers on stones, many different views of coordinates for the board and many others.

- **History of viewed games** is available. User can open any of recently closed games.
- **Export game records** (full or part) in SGF format is possible.
- **Simple closing of the active window** with the Esc key enabled. Lock window feature prevent user from accidental closing of important window.
- **Multilanguage interface.** Changes program interface language.

For now there are three languages enabled: Chinese, English and Russian.

There is very easy to create user native language interface. Just find file English.lng in your BIgo Assistant directory, rename it to Your_Language_Name.lng and translate all (or part) strings from this file. You have to write translation after '=' sign. New language will appear in the menu 'Language' automatically.

- **Game information (if exists) also enabled in different languages.** Default language is English.

Go Board

- **Easy board resizing and game navigation.** Game navigation possible from keyboard, Control Panel (by clicking Toolbar buttons or from menu: View -> Navigation) and with mouse wheel as well.
- **All types of symmetries and rotations of the board are supported.** User can change board view with right-click menu on board or from the Control Panel Toolbars or Menu (View -> Rotate and View -> Symmetry).
• **Stone color inversion for Joseki windows allowed.** User can adjust not only joseki corner and symmetry but change stones color with right-click menu as well.

• **Duplicate board.** User can create copy of the current active board with one click. This possibility is very useful for exploring different fuseki/joseki starts from one position.

• **Test board.** User can create board window with the copy of position of current active board with one click. So you can try your own variations for testing position.

• **Simple SGF files viewer built-in.** There will be full-featured SGF editor in the nearest future. For now user can open and browse single SGF files and read all files in SGF format from whole directory in the game list and than open and view games from that list.

• You don't need to rotate the board for a more convenient position view after the next move: just click the point symmetrical to chosen letter.

• **Show/hide letters** pointed next move for Fuseki/Joseki windows

• **Show/hide all symmetrical letters** pointed next move for Fuseki/Joseki windows

• **Letter filter** - show/hide letters pointed rare next move for Fuseki/Joseki windows

**Go Games Database/SubBases part - Go games list.**

There are several slightly different types of Games List Windows:

1. Games List for games from Bigo Assistant database
2. Games List for games History
3. Games List for searched games
4. Games List for external games

There are full set of options for each type of list enabled.

```
<table>
<thead>
<tr>
<th>N.</th>
<th>Black player</th>
<th>White player</th>
<th>Result</th>
<th>Date</th>
<th>Komi</th>
<th>Event</th>
<th>Round</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Cho Hunhun</td>
<td>By Ahn Seun</td>
<td>B+R</td>
<td>12.10.1996</td>
<td>8.0</td>
<td>Go</td>
<td>3</td>
<td>Backups</td>
</tr>
<tr>
<td>2</td>
<td>Konojoh Keiji</td>
<td>By Ahn Seun</td>
<td>B+R</td>
<td>12.10.1996</td>
<td>8.0</td>
<td>Go</td>
<td>3</td>
<td>Backups</td>
</tr>
<tr>
<td>3</td>
<td>Konojoh Keiji</td>
<td>By Ahn Seun</td>
<td>B+R</td>
<td>12.10.1996</td>
<td>8.0</td>
<td>Go</td>
<td>3</td>
<td>Backups</td>
</tr>
<tr>
<td>4</td>
<td>Konojoh Keiji</td>
<td>By Ahn Seun</td>
<td>B+R</td>
<td>12.10.1996</td>
<td>8.0</td>
<td>Go</td>
<td>3</td>
<td>Backups</td>
</tr>
<tr>
<td>5</td>
<td>O Hamza</td>
<td>By Ahn Seun</td>
<td>B+R</td>
<td>12.10.1996</td>
<td>8.0</td>
<td>Go</td>
<td>3</td>
<td>Backups</td>
</tr>
</tbody>
</table>
```

Dia. 4. Games List for Game base

With games list user can:

• Sort by: player, white player, black player, event, date, number of moves.
• Search for the game or set of games using ‘Search word’. ‘Search word’ become enabled after global sort execution by some column.
• Search for the game or set of games using ‘Set Filter’.
• View any game from the list by mouse select it and the left double-click mouse or press 'Open game' button.
• Autoview all games from the list by click Ctrl+U or Menu -> Tools -> AutoShow
• Print all games from the list by click Ctrl+P or Menu -> File -> Print
• Change view for each type of list from Tools -> Options -> List.
• Delete game from the current list by click Del button on keyboard.

Columns sorting for 1\textsuperscript{st} type of Games List.
Global sorting for all games sets with left mouse click at the column header. Another left mouse click changes direction of sorting.
Shift + left mouse click at the column header cancelled current Global sorting.
Local sorting for games only from current opened List sets with holding Ctrl button + left mouse click
If you have list already sorted globally, you can add local sorting by another column.
You can set filter for the chosen info field after setting global sorting.

Columns sorting for 2 - 4 types of Games List.
There are only local sorting enable for these types of windows. Left or Right mouse click at the column header switch it on and off.

Filter List
You can create queries of any complexity for filtering Games Bases.
Click 'Set Filter' at the Games List window. The window with the list of Filters will open.
There is possible to add new filter, edit or delete existing unnecessary one.
After click 'Edit' or 'Add' buttons Edit filter window will open.
Let's create filter for all 'Kato Masao - Otake Hideo' games. We can do it at least with 3 different ways.
Different sets operates like ‘or’ operation. Lines for each set connects with ‘and’ operation. Each line consists of:
1. ‘Strings’ – filtering string
2. ‘Location’ – information string at the Game Base which ‘String’ filtering
3. ‘Presence’ – ‘yes’- ‘no’ (include-exclude) operation for current ‘String’.
You can use ‘|’ - or statement or ‘*’ - mask for including any symbols in the begin or end of the statement.
Custom Subbases based on filters, i.e. filter
defines games subset which will be include in current Custom Subbase.

Fuseki/Joseki Database/SubBases part
Fuseki/Joseki Database has a complex graph structure which could be compared with the jungle (not with a tree) because of large amount of branch (variations of fuseki/joseki) intersections. That is why the number of variations in the Fuseki/Joseki Databases much much more then the number of the games at the Games Database.

- Each fuseki/joseki variation ends with an unique game.
- Fuseki/Joseki Databases are also searching indexes to find lists of games for a specific opening (full board/half board/corner positions). User can get a list of the games for each fuseki/joseki position.
- The rank of strongest player who made the current (and previous) move is displayes (i.e. last black and white moves).
- Letters for next fuseki/joseki move are sorted by the winning percentage and could be colored by the players category (pro, semipro, amateur).

Games statistics
Full game statistics for each fuseki/joseki move is enabled. You could see game result statistics by different categories of players (pro+semipro, strong ama players, other and total).
There are two different statistics for fuseki/joseki moves:
Statistics by variation. If selected position can be reached in different ways, the program shows game statistics for the current variation and for the position in total.
Statistics by position. This type of statistic is always accessible.

**Games statistics for the next move**
User can define statistic graph for the next move.
You can see default view 'Statistics for the next move' at the Dia. 6.

![Dia. 8](image)

Red bar means that professional players made pointed move.
Green bar means that semi professional players made pointed move.
Dark blue (navy) bar means that pointed move made players from other categories (strong ama, ama etc).

You can change bar view from horizontal to vertical and back with 'View' submenu of right-click mouse menu (Dia. 9).

![Dia. 9](image)

With right-click mouse menu you can change sorting order for letters on the board and on the graph.

**1st Sorting Criterion** (Dia. 10)
- 'Group' - Played games for specific next move divides on groups by strength (pro, semipro, etc).
- 'Rank' - Played games for specific next move divides on groups by rank of strongest player who made that move.

**2nd Sorting Criterion** (Dia. 11)
- 'Total' - Total number of games for specific next move
- 'Relative Total' - number of games for specific next move calculated by built in formula
- 'Win' - Total number of winning games for specific next move
'Relative Win' - number of winning games for specific next move calculated by built in formula

Open Fuseki for the game
If you load external sgf file with the game for view, it could be interesting to know other possibilities to play fuseki for this game.
Choose ‘Tools’ -> ‘Open Fuseki for the game’ menu item or button and new full board fuseki window will open. In this window you will see position - fuseki exit point for given game. This is usual full fuseki window with all functions enabled.
So this way you can explore fuseki for your game.

Search for a specific position.
User do not need to use this mode too often because all Fuseki/Joseki Databases is already prebuilt.

Dia. 12
In Search mode user defines arbitrary (not only rectangle) part (single or multiple) of the board for searching games from any Fuseki/Joseki window. Shadowed part of the board in the picture is excluded one. You can put black and white stones in any parts of the board. Stones in light part are configures position for search. Stones in the shadowed part have special meaning. Blank shadowed board point, naturally, means that in this point can be black stone, white stone or nothing. Black stone in the shadowed board point, means that in this point can be black stone or nothing. White stone in the shadowed board point, means that in this point can be white stone or nothing.

Let's try to find follow position from Full Board Fuseki of Pro Sub Base (Tiny Database)

After settle position, you can change search options in Control panel.
Search options means exactly that is written. 'Clear' button clears board from the search pattern. For usual cases you have not need change any setting.

Simply click 'Search' button for search or 'Cancel' button for cancellation.

In a few moments you will see:

Given position were found in two games. You can select any of them and open. Game opens automatically in searching position with proper board symmetry settings.

Print Data
Bligo Assistant have extended printing facilities. With just several mouse clicks you can print, for example, several games (on one, two or more diagrams each) or subtrees of Fuseki/Joseki variations. There are possible to print:
- Game or set of games
- Fuseki/Joseki variation or variations subtree
- Position
- Games List
Print game(s)

You can print game from any Game List window including Game History or from Board with a game.

If you will select more than one game in the list, the set of games with the same options will print.

For print game(s) you can leave default printing options or change one or more from them:

1. Set Page Setup->General->Diagram Type to Game.
2. Set Page Setup->General->From Move Number to 1
3. Set Page Setup->General->To Move Number to 0 (if you want to print all game) or specify number of moves if you want print part of the game.
4. Set Page Setup->General->Diagrams Numbering depends on type of numbering you want.
5. Set Page Setup->General->Max Number of diagrams depends on number of diagrams for thr game you want.
6. Set Page Setup->General->Moves per Diagram
7. Set diagram size and so on in Page Setup->Diagrams.
8. Set Info fields and their order for game header output in Page Setup->Game Info

Print Fuseki/Joseki variation or variations subtree

You can print any part of fuseki/joseki tree from any database (Full, Professional etc).

To do list for that is follow:

1. Open fuseki/joseki window and place position from which you want start variation subtree print.
2. Set Page Setup->General->Diagram Type to Variation.
3. Set Page Setup->General->To Move Number to the number where variation subtree finish.
4. Set Page Setup->General->Max Number of diagrams to big number (for example 100).
5. Set diagram size and other options in Page Setup->Diagrams.
6. Parameter Page Setup->General->From Move Number have determined as 1 and can not be changed.

Let's consider very simple example.

We want to print all diagrams from follow Pro Base joseki only one move deep.

![Diagram 16](Dia. 16)

If we set Page Setup->General as shown here

![Page Setup](Dia. 17)
Page Setup->Diagrams as shown here

Dia. 18.

If you do not want to see move numbers for initial position, switch off
Page Setup->Diagrams->Show move numbers for the 1st dia.
Look at the diagrams header.

Dia. 19.
You can hide it all by switching off
Page Setup->Diagrams->Show Diagram Header.

#2 is a diagram number. You can do not output it by switching off
Page Setup->Diagrams->Show Dia Numbers.
1(6) means: only one move 1 output (with absolute number 6).
a (1) means: this diagram is 'a' continuation of the dia. 1. Next move will be black. You can do
not output it by switching off Page Setup->Diagrams->Additional info.

Main distinctions between BIgo Assistant and other Go databases.

Main differences in physical construction BIgo Assistant from other Go Database programs are:
- Game database size exceeds another Go databases more than 30 times. Because of this Fuseki analyzer (described later) became useful tool.
- Fuseki/Joseki databases are prebuilt and also prebuilt main searching indexes. Because of this program response is extremely fast even in comparing with other programs with much much less size of databases.

Unique BIgo Assistant features

*Go back with different ways - Multiple back reference (if possible).*

For Fuseki/Joseki diagram window. If you see the small cross(es) on the stone(s) in addition to the big cross on stone with the last move (like in picture) that is means there is(are) different position(s) from which you can get current one. Simple click mouse on small cross to go Fuseki/Joseki back with another way. At the Dias 21 – 23 shown all 3 joseki sequences from which arise initial position.

This feature became possible because of special structure of Bigo Assistant databases.
**Bligo Assistant supports multiple source reference.**

There are a lot of games in the database with 4-5 sources. This feature is very convenient for generating using filter games collections from Go books and magazines and store that collections for future use.

**Bligo Joseki**

Bligo Joseki is a Go Joseki browser and editor. The interface of this program is very similar to Bligo Assistant interface and for Full version of the program Bligo Joseki built in it.
Main features of the program

1. Browse and print joseki variations tree.
   There are about 10 000 corner patterns (more than 120 000 moves) have been manually
   input from many Go books. Because of unique algorithm of tree builder (find and
   merge same positions) number of variations were increased to 22700 and number moves
   to 365 000.

2. Input and delete new josekies.
   User can input new moves with simple mouse click if you check off “Read Only” in the
   Edit menu.

3. Input and edit commentaries.
   User can input and edit short (prefabricated) and long (user text) commentaries for each
   joseki move in a different languages and with a source reference. There is a possible to
   input several commentaries (from different sources, for example) for one move.

4. Import joseki from SGF files.
   You can import easily another Joseki database (in SGF format) into BIgo Joseki.

How to improve in Go with BIgo Assistant

You can use BIgo Assistant as regular reference. Though there are no literally estimation of
move quality for Fuseki/Joseki variations, user have enough information for evaluation moves
and positions. Control Panel shows rank of strongest player, which made last moves for black
and white and two kinds of game statistics which already described.

Here the list of some other Go studying tasks:

1. Study full board fuseki in general (guess mode) or investigate specific fuseki patterns.
   Example,
   a. Create Custom Subbase or Filter, if you need only game records: Cho Chikun
      plays white against Takemiya Masaki (black). You will get a lot of pure struggle
      patterns: "white territory against black influence built from sanrensei ". Besides
      fuseki you can study sophisticated invasion technique of Cho Chikun as well.

2. Study joseki. There is very important that you can get list of games for each step of any
   variation. There are milliards variations in Joseki Database. So you can study them very
   seriously.
   Example,
   a. Alexander Dinerstein (1 dan pro) use BIgo
      Assistant for professional and amateur games
      commentaries for http://go4go.net. In some of
      that games appears very new for professional
      playing joseki variations. Since in our database
      more 1 million high rank ama games, most of
      such variations already have tried by them. Let’s
      look at the joseki appears in the game from 3rd
      KAT cup, Korean Team Championship between
      Kim Myeongwan, 6-dan (black) and Song
      Taekon, 4-dan (white) (game #44 from the list
      of commentaries pro games at the http://go4go.net/procomments). New joseki
      move made black (stone with cross at the Dia.
25). Dia 26 shows possible professional moves in this position (from Bigo Assistant Profi Database). There are no move from Dia. 25. Dia. 27 shows position 2 moves later and 3 possible next moves from Full Joseki database. There were 85 (!) games of high level amateurs with this joseki found. Based on these variations Alexander Dinerstein made his analysis of new professional joseki.

3. Since half board fuseki is already prebuilt you can study joseki patterns in conjunction with position at the neighbour corner or side formations like Chinese style, san-ren-sei and others for only this part of the board.

4. Simple study professional games: just viewing or more active – guess mode. You can use guess mode for specific game (this is very standard feature) or start it from full board fuseki.

5. More sophisticated study professional games. You can create Player Subbase or Custom Subbase and study only that games. You can choose to play against or as your favorite player (to learn his style, e.g., Takemiya Cosmic style and Kobayashi Methodical style, etc.)

6. Position search is a powerful tool with several options allows to study specific game positions for arbitrary parts of the board.
Fuseki Analyzer

Because of huge amount of games our Fuseki Analyser became very useful tool. You can check your own game flow with different possibilities of playing in all board parts with one mouse click.

With this tool you can analyze games form Blgo Assistant database or external games stored in SGF format.

Analyzed game shows in central full board window. In this window you can see whole game and possible opening moves from Full Fuseki database. Eight windows reflects possible continuations of the game in correspondence parts of the main board. You can explore variations in all windows independently.

When the program could not find continuation of the variation for specified part of the board, it stops variation in the correspondent window.

You can make any from 9 windows active placing mouse on that window (you need not click on the window!). Control Panel shows Statistics for current and next move for active window.
Ideal Go Database

Now we can check how BIgo Assistant features meets aspirations for the good Go database formulated Cho Chikun game collector and computer Go expert Jan van Rongen (http://www.xs4all.nl/~rongen17/Topics/topic001.html)

“Need to have”

1. Managing the games collection
   1.1. Import sgf files, check syntax and, if possible, correct it if wrong  
        Done only for Base version
   1.2. Signal duplicate games in the collection and/or avoid importing duplicates (using some sort of Dyer signature)  
        Done only for Base version
   1.3. Export selected files in sgf format without any loss of data  
        Done
   1.4. Delete selected files from the database  
        User can delete games virtually from Games Lists.
   1.5. On at least 50,000 games with good performance  
        Done

2. Searching for serious students
   2.1. On game data (such as player, date, tournament, round)  
        Done
   2.2. On joseki patterns  
        Done
   2.3. On fuseki patterns  
        Done
   2.4. Combination of above  
        Done
   2.5. Show follow up moves and percentages played; win/loss  
        Done

3. Quality of data
   3.1 Know and link different ways of writing names of the same player  
        Done
   3.2 Do not throw away any game data on import.  
        Done
   3.3 Keep variation trees and comments intact.  
        Not yet

"Nice to have"

1.6 Multiple games collection  
        Done only for Base version
1.7 Manage tournament data for which you do not have the games themselves  
        No

2.6 Export Joseki or Game variation trees  
        Easy to made. We don’t sure that it’s necessary.
2.7 Integrated high quality game viewer and editor  
        Only viewer for now
2.8 Integrated Joseki and Fuseki library (tells you the variations that never occur in actual games).  
        Done